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TOSVERT VF-MB1/S15 series
EtherCAT
1. Read this manual before installing or operating. Keep this instruction manual on hand
of the end user, and make use of this manual in maintenance and inspection.
2. All information contained in this manual will be changed without notice. Please
contact your Toshiba distributor to confirm the latest information.
Phone: 800.894.0412 - Fax: 888.723.4773 - Web: www.clrwtr.com - Email: info@clrwtr.com
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Page 3 E6581818 Handling in general Warning Do not connect or disconnect a network cable
while the drive power is on. It may lead to electric shocks or fire. Prohibited See the instruction
manual attached with the option unit for cautions the handling. Otherwise, it may lead to
electric shocks, fire, injuries or damage to product.

Page 4: Table Of Contents
4.5. Application Profile (CiA402) .......................15 4.6. Abort code (CiA 301)..........................16
DRIVE PROFILE............................17 5.1. CiA 402 Drive profile ..........................17 5.2. TOSHIBA
Drive profile ........................17 ® 402 – IEC61800-7 FUNCTIONAL PROFILE..................24 6.1.
Velocity mode object ..........................24 6.1.1. CiA 402 profile ..........................24 6.1.2.

Page 5 E6581818 8.9. PLC – Control: Declare the variables....................42 8.10. System
Manager – Append PLC Project..................43 8.11. PLC - Control: new
compilation......................45 8.12. System Manager: Activate configuration..................45 8.13.
PLC - Control: new compilation......................45 8.14. PLC - Control: start and stop the
motor..................45 8.15.

Page 6: Overview
• EtherCAT state machine commands • Emergency (EMCY) ESI file (EtherCAT Slave Information)
Download the ESI file in XML format for VF-MB1 and VF-S15 on Toshiba website. - 5 - Phone:
800.894.0412 - Fax: 888.723.4773 - Web: www.clrwtr.com - Email: info@clrwtr.com...

Page 7: Names And Functions
E6581818 2. Names and functions The drawing below shows names and functions of main
parts. 2.1. Outline Connector to the inverter LED indicator (See 2.3) L/A X1 X2 L/A Shielded
female RJ45 Shielded female RJ45 Ethernet Connector Ethernet Connector Release tab (Port IN)
(Port OUT) X1 means EtherCAT IN port,...

Page 8: Rj45 Connector Pin Layout
E6581818 2.2. RJ45 connector pin layout ® The EtherCAT unit is equipped with two shielded
RJ45 connectors. When you use VF-MB1, the shielding is connected to the drive ground. When
you use VF-S15, the shielding is connected to the grounding terminal of option adapter. Use an
STP (shielded twisted pair) Ethernet cable.

Page 9: Led Indicator
E6581818 2.3. LED indicator The LEDs shows the present status of the network and module. X1
L/A L/A X2 The behavior of X1 L/A LED and L/A X2 LED These LEDs indicate the status of the
EtherCAT IN port (X1 L/A) and OUT port (L/A Color and behavior Meaning No link...

Page 10: Parameters
E6581818 3. Parameters 3.1. Communication parameters Set up the drive parameters as
follows. It is necessary to reset the drive to update the parameter. This option doesn't operate if
these parameters are not correctly set. Communi Title Function Description Setting cation No.

Page 11 E6581818 Communi Title Function Description Default cation No. 0: None 100* 1:
fd01 (Inverter status 1) 2: fd00 (Output frequency, 0.01Hz) 3: fd03 (Output current, 0.01%) 4:
fd05 (Output voltage, 0.01%) 5: fc91 (Inverter alarm) 6: fd22 (PID feedback value, 0.01Hz) 7:
fd06 (Input terminal status) 8: fd07 (Output terminal status) 9: fe36 (VIB input, 0.01%)

Page 12 E6581818 Communi Title Function Description Default cation No. 0: Disconnection
detection 1: When communication mode enable (Both Communication time-out c103 cmod and
fmod are set CANopen or C103 condition selection communication option) only 2: 1 + Driving
operation 1: INIT Initialization 2: PREOP Pre-operational...

Page 13: The Details Of The Parameter Setting
E6581818 3.3. The details of the parameter setting Network error detection (c100 - c103) 3.3.1.
▼Display of trip information err8 (Optional unit fault 1: 0x001B): Network error stop ▼Related
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parameter Title Function Setting range Description The waiting time from when a network error
occurs can be adjusted.

Page 14: Communication Object
0x00 string This value depends on the drive name. 0x00 0x04 ID object: Number of objects ID
object: Supplier ID 0x01 0x00000284 0x00000284 : Toshiba Schneider Inverter Co. 0x1018
0x02 0x000000E1 Product code 0x03 0x00010002 Revision number 0x04 Serial number...

Page 15: Rpdo: Receive Pdo
E6581818 4.2. RPDO: Receive PDO Index Access Type Default value Description index Receive
PDO mapping – Number of mapped object: 0 to 4 0x00 0x02 objects can be mapped for this
PDO Receive PDO mapping – 1st mapped object: Control word 0x01 0x60400010 “CMD”...

Page 16: Application Profile (Cia402)
E6581818 4.5. Application Profile (CiA402) These are contains standardized parameters in
conformance with CiA402 velocity mode. Default Index Access Type Description index Mapping
value 0x603F 0x00 0x0000 Error code 0x6040 0x00 0x0000 Control Word 0x6041 0x00 0x0000
Status word 0x6042 0x00 0x0000 Vl_Target_Velocity (min...

Page 17: Abort Code (Cia 301)
E6581818 4.6. Abort code (CiA 301) The abort code in the below table are set in the error
response data. Abort Code Contents 0503 0000 Toggle bit not alternated. 0504 0000 SDO
protocol timed out. 0504 0001 Client/server command specifier not valid or unknown. 0504
0002 Invalid block size (block mode only).

Page 18: Drive Profile
5.2. TOSHIBA Drive profile Using TOSHIBA Drive profile, form EtherCAT network, the drive can
be controlled. TOSHIBA Drive profile is operated when conditions are not right in CiA 402 Drive
profile. - 17 - Phone: 800.894.0412 - Fax: 888.723.4773 - Web: www.clrwtr.com - Email:
info@clrwtr.com...

Page 19 E6581818 5.2.1.1. fa06 (Communication command1) Function Note Preset speed
operation frequencies Preset speed operation is disabled or preset speed operation Preset
speed frequencies (1-15) are set by operation frequencies specifying bits for preset speed
operation frequencies 1-4. Preset speed (0000: Preset speed operation OFF, operation
frequencies 001-1111: Setting of preset speed operation frequencies (1-15)

Page 20 E6581818 5.2.1.2. fa23 (Communication command 2) Function Note (Reserved)
Electric power quantity Electric power quantity (fe76, Reset fe77) reset reset (Reserved)
(Reserved) (Reserved) (Reserved) (Reserved) Maximum deceleration Normal Enabled forced
stop Select acceleration/deceleration Acceleration/decele- 00: Acceleration/deceleration 1 1-4
by combination of two bits.. ration selection 1 AD1: acc, dec 01: Acceleration/deceleration 2...

Page 21 E6581818 5.2.1.3. fa07 (frequency reference from internal option) Frequency
reference is set up by 0.01Hz unit and the hexadecimal number. For example, when "Frequency
reference" is set up to 80Hz, since the minimum unit is 0.01Hz, 80 / 0.01 = 8000 = 0x1F40
(Hex.) 5.2.1.4.

Page 22 E6581818 5.2.1.6. fd01 (Inverter operating status 1 (real time)) Function Note Under
in Failure FL No output progress Trip status includes rtry and Failure Not tripped Tripped the trip
retention status are also regarded as tripped statuses. Alarm No alarm Alarm issued Under
voltage (moff) Normal...

Page 23 E6581818 5.2.1.8. fd03 (Output current (real time)) The output current is read into
0.01% of units and by the hexadecimal number. For example, when the output current of the
rated current 4.8A drive is 50% (2.4A), 0x1388 (hexadecimal number) is read out. Since the
minimum unit is 0.01%, 0x1388 (Hex.) = 5000 (Dec.) * 0.01 = 50 (%) Also about the following
parameters, these are the same as this.

Page 24 E6581818 5.2.1.12. fc91 (Alarm code) Remarks Function (Code displayed on the
panel) c flicking Over-current alarm Normal Alarming l flicking Inverter over load alarm Normal
Alarming l flicking Motor over load alarm Normal Alarming h flicking Over heat alarm Normal
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Alarming p flicking Over voltage alarm...

Page 25: Cia ® 402 - Iec61800-7 Functional Profile
E6581818 ® 6. CiA 402 – IEC61800-7 Functional Profile Functional description: Drive operation
involves two main functions, which are illustrated in the diagrams below: 6.1. Velocity mode
object 6.1.1. CiA 402 profile The main parameters are shown with their CiA402 name and their
CiA402/Drivecom index (the values in brackets are the CANopen addresses of the parameter).

Page 26: Toshiba Drive Profile
E6581818 6.1.2. TOSHIBA drive profile These diagrams translate as follows for the MB1/S15
system: Control diagram: State- Communication command 1 Inverter operating status 1
machine (0x2A06) (0x2D01) Simplified diagram of speed control in “Velocity” mode: Frequency
reference Inverter operating status 1 (0x2D01)

Page 27: Object 0X6040: Controlword
E6581818 6.1.3. Object 0x6040: Controlword ms = manufacturer-specific (bit11: 0 = Forward
direction asked, 1 = Reverse direction asked); r = reserved; oms = operation mode specific; h
= halt; fr = fault reset; eo = enable operation; qs = quick stop; ev = enable voltage;...

Page 28 E6581818 Status bit 6 bit 5 bit 4 bit 3 bit 2 bit 1 bit 0 Status Word Switch on Quick
Voltage Fault Operation Switched Ready to disabled stop enabled enabled switch on 6 - Quick
0x0017 stop active  ...

Page 29: Cia402 State Chart
E6581818 6.1.5. CiA402 State Chart Description of States Each state represents an internal
reaction by the drive. This chart will change depending on whether the control word is sent
“CMD” or an event occurs (a detected fault, for example). The drive state can be identified by
the value of the status word “ETA.” State Drive internal reaction 1- Not Ready to switch on...

Page 30 E6581818 State Drive internal reaction 7 - Fault reaction active Transient state
during which the drive performs an action appropriate to the type of detected fault. The drive
function is activated or deactivated according to parameter f603 when detected the emergency
stop. 8 - Fault Drive has detected a fault.

Page 31: Object 0X6042: Vl_Target_Velocity
E6581818 6.1.6. Object 0x6042: vl_target_velocity This object shall indicate the required
velocity of the system. The value is given in revolutions per minute (min ). Positive values
forward direction and negative values indicate reverse direction. At changing to “Operation
enable” state, this target velocity is cleared. So set this target velocity data after changed the
state to “Operation enable.”...

Page 32: Object 0X6048: Vl_Velocity_Acceleration
E6581818 6.1.10. Object 0x6048: vl_velocity_acceleration This object indicates the configured
delta speed and delta time of the slope of the acceleration ramp. Velocity Acceleration Delta
Speed : 225 to 30,000 min Velocity Acceleration Delta Time : 0.1 to 3,600 s Note: Do not
change the acceleration/deceleration time unit (parameter f519), if change the parameter, the
setting value range will be different from above range.

Page 33: Object 0X6060: Mode Of Operation
E6581818 6.1.14. Object 0x6060: Mode of operation The object shall indicate the requested
operation mode. This module supports the “vl (= 2)” (velocity mode) only. NOTE: This object
shows only the value of the requested operation mode, the actual operation mode of the PDS*
is reflected in the object modes of operation display. *PDS: Power drive system Value
Definition...

Page 34: Object 603F: Error Code
E6581818 6.2. Object 603F: Error Code Below table describes the relations of the error code and
drive error. Error Drive trip Drive error Meaning Drive condition code code name 0x0000 No
error 0x00 0x0E Motor overload err2 0x15 Main unit RAM fault err3 0x16 Main unit ROM fault...

https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=25#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=26#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=27#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=28#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=29#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=30#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=31#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=32#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=33#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=34#manual


Page 35: Ethercat State Machine (Esm)
E6581818 7. EtherCAT State Machine (ESM) ESM Diagram The EtherCAT State machine
coordinates the master and slave applications at start up and during operation. State changes
are typically initiated requests of the master. They are acknowledged by the local application
after the associated operations have been executed.

Page 36 E6581818 State transitions State transition Local management service Value Start
Mailbox Communication 0x02 Stop Mailbox Communication 0x01 Start Input Update 0x04 Stop
Input Update 0x02 Start Output Update 0x08 Stop Output Update 0x04 Stop Output Update and
Stop Input Update 0x02 Stop Input Update, Stop Mailbox Communication 0x01...

Page 37: Example: Vf-Mb1 With Twincat "Plc - Configuration
The ESI file must be integrated into the system on the master controller. For example (directory
pass): C:¥TwinCAT¥Io¥EtherCAT As for acquisition of an ESI file, please contact your Toshiba
distributor. 8.4. MB1 configuration Realize the configuration on the Drive for Operation With
CiA402 Profile in Combined Mode.

Page 38: System Manager: Declare Your Computer On Ethernet Network
E6581818 8.5. System Manager: Declare your computer on Ethernet network ® ® Start
TwinCAT system-manager Select Options -> “Show Real Time Ethernet Compatible devices”
Select your Computer Ethernet board, and “Install”.  Enable it. - 37 - Phone: 800.894.0412 -
Fax: 888.723.4773 - Web: www.clrwtr.com - Email: info@clrwtr.com...

Page 39: System Manager: Install The Master
E6581818 8.6. System Manager: Install the master ® In this example we use the computer to
run TwinCAT and PLC runtime as Mater.  Select “Choose Target”  Select “Search (Ethernet)” 
Start the “Broadcast Search”  Select your Master in the Host Name list (your computer in this
example) - 38 - Phone: 800.894.0412 - Fax: 888.723.4773 - Web: www.clrwtr.com - Email:
info@clrwtr.com...

Page 40 E6581818  Check that you are in “config mode” - 39 - Phone: 800.894.0412 - Fax:
888.723.4773 - Web: www.clrwtr.com - Email: info@clrwtr.com...

Page 41: System Manager - Install The Slave: Mb1 In "Plc- Configuration
E6581818 8.7. System Manager – Install the slave: MB1 in “PLC- configuration”  Select the I/O
Devices -> Scan Devices  Choose the “OK.”  Check the “Device 1[EtherCAT]” -> Choose the
“OK.”  Choose the “Yes”.  Choose the “Yes.” ...

Page 42: Plc - Control: Initialization
E6581818 8.8. PLC – Control: initialization ® Start TwinCAT PLC control software File -> new
ST: Structured language Select; Resources -> Library Manager Add EtherCAT libraries Add
TcEtherCAT.lib All EtherCAT libraries are added: - 41 - Phone: 800.894.0412 - Fax:
888.723.4773 - Web: www.clrwtr.com - Email: info@clrwtr.com...

Page 43: Plc - Control: Declare The Variables
E6581818 8.9. PLC – Control: Declare the variables Select Global_Variables Create the Master
Global_Variables for MB1 as below. Copy/paste the variables: VAR_GLOBAL MB1_State AT
%I*:WORD; PLC_state AT %I*:UINT; MB1_TPDO_Input1_Status_Word AT %I*:WORD;
MB1_TPDO_Input2_Control_Effort AT %I*:WORD; MB1_TPDO_Input3 AT %I*:WORD;
MB1_TPDO_Input4 AT %I*:WORD; MB1_TPDO_Input5 AT %I*:WORD;...

Page 44: System Manager - Append Plc Project
E6581818 Add 1 instruction minimum in POUs before rebuild; Select: Project -> Rebuild All
Check the compilation result without error. This action creates file in: C:¥TwinCAT¥Plc As
example, create: TSB_MB1_sample.tpy 8.10. System Manager – Append PLC Project In System
Manager software, realize the link between the Master and the slave. Creation of the links
between “PLC –...

Page 45 E6581818 Example for “MB1_State” Links to create PLC – Configuration I/O -
Configuration Inputs MB1_State State Inputs PLC_State DevState (with Device1) Inputs
MB1_TPDO_input1_Status_Word Status word Inputs MB1_TPDO_input2_Control_Effort Control
effort Inputs MB1_TPDO_input3 Available for other parameter Inputs MB1_TPDO_input4
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Available for other parameter Inputs MB1_TPDO_input5 Available for other parameter...

Page 46: Plc - Control: New Compilation
E6581818 8.11. PLC - Control: new compilation Select: Project -> Rebuild All This action updates
the information. 8.12. System Manager: Activate configuration Select: Actions -> Activate
Configurations 8.13. PLC - Control: Run Select: Online -> login Select: Online -> Run The PLC
and the EtherCAT fieldbus are now running.

Page 47: Plc - Control: Add A Library For Other Services
E6581818 8.15. PLC - Control: add a library for other services Install the library: TcEtherCAT.lib
Example for exchanges with SDO - 46 - Phone: 800.894.0412 - Fax: 888.723.4773 - Web:
www.clrwtr.com - Email: info@clrwtr.com...

Page 48: Method Of Add The Pdos
E6581818 Example for exchanges with ESM states 8.16. Method of add the PDOs Select the
“Process Data” tag Select the “PDO List” (Inputs or Outputs) Select the “PDO content” Right
click and select the “Insert…” - 47 - Phone: 800.894.0412 - Fax: 888.723.4773 - Web:
www.clrwtr.com - Email: info@clrwtr.com...

Page 49 E6581818 Set the Name of PDO Set the Index of PDO Set the Sub Index of PDO Set
the Data Type of PDO - 48E - Phone: 800.894.0412 - Fax: 888.723.4773 - Web: www.clrwtr.com
- Email: info@clrwtr.com...

This manual is also suitable for:
Tosvert vf-s15

https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=46#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=47#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=48#manual
https://capturecode.com/manual/1409662/Toshiba-Tosvert-Vf-Mb1.html?page=49#manual
https://capturecode.com/products/Toshiba-Tosvert-Vf-S15-Series-2975064.html

